[ #routerboard ][ #mikrotik ][Tips] 也许可能更多的是,RouterOS的提示 2017

     
    • 最終更新日時:2017/11/04 14:22:38

    Embed
    bbf61c46-7699-45b8-a1d0-1c9ab2dccc78.png

    題名を中国語(簡体字)で表記したことについては、特に意味がありません。

    本当は向こうに書こうか迷ったのですが、まぁメモ代わりということもあるので、こちらに書きます。
    実は設定で漏れていたりしませんか、という内容になります。

    まず最初にPath MTU Discovery (PMTUD)について。

    これって調べてみると深い問題なんですね。
    重要度についてはあまり理解していませんでした。

    YAMAHA RTXシリーズだと以下の設定パラメータになると思います。
    ip tcp mss limit auto

    9.1.20 TCP セッションの MSS 制限の設定

    TCPのMSSサイズの制限については、RouterOSのFirewallのデフォルトルールには無かった気がします。
    ただ、iptablesの設定例で調べてみると案外出てくるんですね。
    ipv4については、「MTU」と「MRU」を1454などに設定する必要があるので、大きく影響することは少ないのですが、ipv6については影響が大きいようです。

    UDPとICMPの深いぃ話 /
    https://www.nic.ad.jp/ja/materials/iw/2014/proceedings/t2/t2-matsuhira.pdf
    PowerPoint Presentation /
    https://www.janog.gr.jp/meeting/janog34/doc/janog34-6pmtu-kunitake-1.pdf
    IPv6とTCP MSSの調整

    というわけで、以下のFirewallルールをipv4、ipv6とも追加しておいたほうが良いでしょう。
    /ip firewall mangle
    add action=change-mss chain=forward comment="Clamp MSS to PMTU" \
    new-mss=clamp-to-pmtu passthrough=yes protocol=tcp tcp-flags=syn

    /ipv6 firewall mangle
    add action=change-mss chain=forward comment="Clamp MSS to PMTU" \
    new-mss=clamp-to-pmtu passthrough=yes protocol=tcp tcp-flags=syn

    RouterOSの場合は、これでTCP MSSの自動調整が機能するようになります。

    参考情報:

    教科書にない、PMTUDにまつわる挙動 - Qiita

    本家の 資料によると、92%がworksと書いてある。 当然、自分も無意識に使っているはず。どんなものか見てみたい。 そこで、Wireshark。すると... 確かに出ているが、一瞬だけ。その後は、見慣れたSSL/TLSが、どばーっと。 いきなり8%にご当選か。不幸だー。 Google様のテクノロジーの恩恵を受けたいじゃないの。 我が家にはNOC(A)とNOC(B)があり、NOC(A)=v4/v6デュアルスタックのISP、NOC(B)=v4シングルスタッ




    その2。

    過去にこのような記事を書いているのを覚えている方はいらっしゃいますでしょうか。

    いつか、そのとき、あの場所で。 | [ #routerboard ][ #mikrotik ] RouterOSでCountry Blockを使用する方法。 /
    https://kometchtech.blog.fc2.com/blog-entry-1544.html

    これはかなり有用な機能の追加になるのですが一つ問題が。
    この手の機能を使用した方はわかると思うのですが、大量のaddress-listの入れ替えが発生するため、logにその旨のメッセージが大量に出力されてしまうことです。十数行ならまだしも数千行になると、一気にlogの可読性が落ちます。

    ということでこれを防ぐ手段です。

    /system loggingのon-eventに以下のように記述すると良いと思います。
    :log warning "Disabling system Logging";
    /system logging disable 0
    <実行したいScript>
    :log warning "Enabling system Logging";
    /system logging enable 0

    気がついた人もいるかもしれません。これは/system loggingの0番を無効にしたり有効にしたりする方法になります。
    0番に該当するのはinfo/memoryになり、今回のようにinfoレベルのlogが出力される際のフラグになります。
    これを一時的に無効にすることで、logの大量出力を防ぎます。

    ただ、この無効化を忘れたままにしていると、重要なlogを逃す可能性がありますので、実装する際は十分に注意するようにしましょう。
    上にもあるように、「:log warning "Enabling system Logging";」のような形で、予めメッセージを出力するようにしてあげるのが良いと思います。



    関連記事


    Pagination

    Trackback

    Trackback URL

    https://kometchtech.blog.fc2.com/tb.php/2071-48e079ee

    Comment

    Post Your Comment

    コメント登録フォーム
    公開設定

    Utility

    Profile

    kometch

    Author:kometch
    なんちゃってエンジニアです。
    2009年10月から業務都合により大阪勤務になりました。
    2010年1月、HYBRID W-ZERO3を購入しました。
    2010年11月、HTC Desire HDを購入しました。
    2012年2月、都内の会社に転職しました。
    2012年5月、HTC One Xを購入しました。
    2012年8月、事情により休職しました。
    2012年8月、SONY Xperia SXを購入しました。
    2013年1月、一身上の都合により退職しました。
    2014年3月、都内の会社に就職しました。
    2016年8月、HPC系の会社に転職しました。

    Amazonほしい物リスト
    何か問題などありましたら、こちらまで。 Twitter:@kometchtech follow us in feedly

    カレンダー

    10 | 2017/11 | 12
    - - - 1 2 3 4
    5 6 7 8 9 10 11
    12 13 14 15 16 17 18
    19 20 21 22 23 24 25
    26 27 28 29 30 - -

    全記事(数)表示

    全タイトルを表示

    バロメーター

    カテゴリー

    カテゴリークラウド

    アーカイブ

    検索フォーム

    FC2カウンター

    現在の閲覧者数

    現在の閲覧者数:

    Amazonアソシエイト

    スポンサードリンク

    月間ページランキング

    ブログパーツ

    サイトランキング

    スポンサードリンク

    スポンサードリンク