[ #mikrotik ][ #routerboard ][script] 動的に生成されるVirtualAPのqueueを一括変更するスクリプト。

    • 2014/06/10 11:05:16
    • Category: mikrotik
     
    • 最終更新日時:-0001/11/30 00:00:00

    RouterOS 6.14から正式にリリースされるCAPsMANなのですが、その中でwireless-fpパッケージというFast Path Modeが搭載されたパッケージが別途追加されています。
    こちらについてはフォーラムなどを参照して欲しいのですが、こちらを使用するにあたって、interface-queueを”only-hardware-queue”にしないといけないという問題があります。

    しかしながら、CAPsMANを使用してVirtualAPを作成すると動的に作成されてしまうため、その都度設定を行う必要があります。そして、今のところ設定を固定する方法が無いためでもあります。

    ということで一定間隔ごとにinterface-queueを変更するスクリプトを書いてみました。

    スクリプト自体は以下の様な感じになります。

    /queue interface
    set [find interface~"wlan"] queue=only-hardware-queue

    queueインターフェースに対して、正規表現を使用して(find interface~"wlan"の部分に当たります)、返ってきたwlanインターフェースに対して”only-hardware-queue”を指定するものになります。

    これを改めてSchedulerに登録します。
    Winboxからでも問題無いですが、今回はCLIで実施します。

    /system scheduler
    add interval=1m name=enable_wifi_fpmode on-event="/queue interface\r\
    \nset [find interface~\"wlan\"] queue=only-hardware-queue" policy=\
    ftp,reboot,read,write,policy,test,winbox,password,api start-time=startup

    start-time=startupで起動時から、interval=1mで1分毎に実行する形を取ってやります。

    以上で、何らかの原因でCAPsMANとの接続が切れてしまい、再度VirtualAPが動的生成されても、最大1分後には”only-hardware-queue”が設定されるようになります。

    参考:
    関連記事


    Pagination

    Trackback

    Trackback URL

    https://kometchtech.blog.fc2.com/tb.php/1516-21405a0d

    Comment

    Post Your Comment

    コメント登録フォーム
    公開設定

    Utility

    Profile

    kometch

    Author:kometch
    なんちゃってエンジニアです。
    2009年10月から業務都合により大阪勤務になりました。
    2010年1月、HYBRID W-ZERO3を購入しました。
    2010年11月、HTC Desire HDを購入しました。
    2012年2月、都内の会社に転職しました。
    2012年5月、HTC One Xを購入しました。
    2012年8月、事情により休職しました。
    2012年8月、SONY Xperia SXを購入しました。
    2013年1月、一身上の都合により退職しました。
    2014年3月、都内の会社に就職しました。
    2016年8月、HPC系の会社に転職しました。

    Amazonほしい物リスト
    何か問題などありましたら、こちらまで。 Twitter:@kometchtech follow us in feedly

    カレンダー

    09 | 2017/10 | 11
    1 2 3 4 5 6 7
    8 9 10 11 12 13 14
    15 16 17 18 19 20 21
    22 23 24 25 26 27 28
    29 30 31 - - - -

    全記事(数)表示

    全タイトルを表示

    バロメーター

    カテゴリー

    カテゴリークラウド

    アーカイブ

    検索フォーム

    FC2カウンター

    現在の閲覧者数

    現在の閲覧者数:

    Amazonアソシエイト

    スポンサードリンク

    月間ページランキング

    ブログパーツ

    サイトランキング

    スポンサードリンク

    スポンサードリンク