[Ubuntu][Wine] Ubuntu 13.04 でWine 1.7.4をインストールする方法。

     
    • 最終更新日時:-0001/11/30 00:00:00

    Embed

    Wine 設定_001

    Wine 1.7.3 Released - Install on Ubuntu 13.04/12.10/12.04/11.10 and Linux Mint 15/13 /
    http://www.tecmint.com/install-wine-on-ubuntu-and-linux-mint/

    上記ではWine1.7.3になっていますが、現在最新は1.7.4のようです。
    $ sudo add-apt-repository ppa:ubuntu-wine/ppa
    $ sudo apt-get update
    $ sudo apt-get install wine1.7

    これでこの記事執筆時最新のWineが導入できると思います。

    Wine自体の設定については以下のコマンド、またはdashから呼び出せます。
    winecfg

    関連記事




    Pagination

    Trackback

    Trackback URL

    https://kometchtech.blog.fc2.com/tb.php/1264-78910c33

    Comment

    74K40

    Ubuntu 13.10 の環境で、

    インストールしようとしたところ、以下のエラーが出て、インストールに失敗しました。
    どうすればよいでしょうか。

    パッケージリストを読み込んでいます... 完了
    依存関係ツリーを作成しています
    状態情報を読み取っています... 完了
    インストールすることができないパッケージがありました。おそらく、あり得
    ない状況を要求したか、(不安定版ディストリビューションを使用しているの
    であれば) 必要なパッケージがまだ作成されていなかったり Incoming から移
    動されていないことが考えられます。
    以下の情報がこの問題を解決するために役立つかもしれません:

    以下のパッケージには満たせない依存関係があります:
    wine1.7 : 依存: wine1.7-amd64 (= 1:1.7.13-0ubuntu1) しかし、インストールされようとしていません
    依存: wine1.7-i386 (= 1:1.7.13-0ubuntu1)
    E: 問題を解決することができません。壊れた変更禁止パッケージがあります。

    kometch

    74K40さん

    見る限り64bit環境でお使いでしょうか?
    そうであるならば、32bitのパッケージが依存しているので以下のようにしてみて状況は変わりませんでしょうか?

    dpkg --add-architecture i386
    apt-get update

    これで再度パッケージのインストールを試みてみてください。
    たぶん、依存関係が解決されると思います。

    > Ubuntu 13.10 の環境で、
    >
    > インストールしようとしたところ、以下のエラーが出て、インストールに失敗しました。
    > どうすればよいでしょうか。
    >
    > パッケージリストを読み込んでいます... 完了
    > 依存関係ツリーを作成しています
    > 状態情報を読み取っています... 完了
    > インストールすることができないパッケージがありました。おそらく、あり得
    > ない状況を要求したか、(不安定版ディストリビューションを使用しているの
    > であれば) 必要なパッケージがまだ作成されていなかったり Incoming から移
    > 動されていないことが考えられます。
    > 以下の情報がこの問題を解決するために役立つかもしれません:
    >
    > 以下のパッケージには満たせない依存関係があります:
    > wine1.7 : 依存: wine1.7-amd64 (= 1:1.7.13-0ubuntu1) しかし、インストールされようとしていません
    > 依存: wine1.7-i386 (= 1:1.7.13-0ubuntu1)
    > E: 問題を解決することができません。壊れた変更禁止パッケージがあります。
    • URL
    • 2014/03/06 10:19

    74K40

    お早い返信ありがとうございます。

    dpkg --add-architecture i386
    を実行したところ、下記のエラーが起きて失敗しました。
    どうすればいいでしょうか。

    dpkg: エラー: 不明なオプション --add-architecture

    パッケージのインストールおよびアンストールについての情報は dpkg --help で参照 [*];
    ユーザ向けパッケージ管理ツールである `dselect' または `aptitude' を使いましょう;
    デバッグフラグの一覧は dpkg -Dhelp で参照;
    強制オプションの一覧は dpkg --force-help で参照;
    *.deb ファイル操作のヘルプは dpkg-deb --help で参照;

    [*] のあるものは大量の情報が出力されます。`less' や `more' にパイプするようにしてください!

    kometch

    74K40 さん

    うまくいきませんでしたか。
    ちょっと調べますのでお時間いただけますでしょうか?

    > お早い返信ありがとうございます。
    >
    > dpkg --add-architecture i386
    > を実行したところ、下記のエラーが起きて失敗しました。
    > どうすればいいでしょうか。
    >
    > dpkg: エラー: 不明なオプション --add-architecture
    >
    > パッケージのインストールおよびアンストールについての情報は dpkg --help で参照 [*];
    > ユーザ向けパッケージ管理ツールである `dselect' または `aptitude' を使いましょう;
    > デバッグフラグの一覧は dpkg -Dhelp で参照;
    > 強制オプションの一覧は dpkg --force-help で参照;
    > *.deb ファイル操作のヘルプは dpkg-deb --help で参照;
    >
    > [*] のあるものは大量の情報が出力されます。`less' や `more' にパイプするようにしてください!
    • URL
    • 2014/03/06 12:08

    74K40

    なぜかわからないのですが、
    wine1.4をインストールしたらどうなるかと思い、

    sudo apt-get install wine1.4
    としたあと、

    sudo apt-get install wine1.7
    としたところ、
    最新バージョンのwine-1.7.13が見事インストールされました。

    なぜか1.6系から1.7系へのアップデートは失敗するようです。

    ありがとうございました。

    kometch

    74K40 さん

    まずは解決おめでとうございます。
    無事にインストールできたとのこと良かったです。

    ただ、私の力不足にてすぐの解決に至らなくて申し訳ありませんでしたー

    今後共よろしくお願いします。

    > なぜかわからないのですが、
    > wine1.4をインストールしたらどうなるかと思い、
    >
    > sudo apt-get install wine1.4
    > としたあと、
    >
    > sudo apt-get install wine1.7
    > としたところ、
    > 最新バージョンのwine-1.7.13が見事インストールされました。
    >
    > なぜか1.6系から1.7系へのアップデートは失敗するようです。
    >
    > ありがとうございました。
    • URL
    • 2014/03/06 12:29

    Post Your Comment

    コメント登録フォーム
    公開設定

    Utility

    Profile

    kometchtech

    Author:kometchtech
    なんちゃってエンジニアです。
    2009年10月から業務都合により大阪勤務になりました。
    2010年1月、HYBRID W-ZERO3を購入しました。
    2010年11月、HTC Desire HDを購入しました。
    2012年2月、都内の会社に転職しました。
    2012年5月、HTC One Xを購入しました。
    2012年8月、事情により休職しました。
    2012年8月、SONY Xperia SXを購入しました。
    2013年1月、一身上の都合により退職しました。
    2014年3月、都内の会社に就職しました。
    2016年8月、HPC系の会社に転職しました。
    2018年6月、Xperia XZ1 compactに機種変。

    Amazonほしい物リスト
    何か問題などありましたら、こちらまで。 Twitter:@kometchtech follow us in feedly

    カレンダー

    07 | 2018/08 | 09
    - - - 1 2 3 4
    5 6 7 8 9 10 11
    12 13 14 15 16 17 18
    19 20 21 22 23 24 25
    26 27 28 29 30 31 -

    全記事(数)表示

    全タイトルを表示

    バロメーター

    カテゴリー

    カテゴリークラウド

    アーカイブ

    検索フォーム

    FCカウンター

    オンライン

    現在の閲覧者数:

    Amazonアソシエイト

    スポンサードリンク

    月間ページランキング

    ブログパーツ

    サイトランキング