[DNS][NSD] NSD 4.0.0 が公開された。

     
    • 最終更新日時:-0001/11/30 00:00:00

    nlnetlabs.nl :: Name Server Daemon (NSD) :: /
    http://www.nlnetlabs.nl/projects/nsd/

    10月29日付ですが、NSD4の正式版に当たる4.0.0が公開されました。

    FEATURES:
    - - documented in doc/NSD-4-features. Change configuration without
    restart, direct nameserver control with nsd-control, support a
    higher number of zones. Higher performance (compared to NSD3).
    - - nsdc is gone. Use kill -HUP for reload (also checks if zonefiles
    have changed and rereads them), and kill -TERM for quit. Or use
    nsd-control for detailed control.
    - - cron job for nsdcpatch is gone. nsd-control write creates zonefiles.
    - - nsd.db has a new format that compacts itself when it is changed,
    thus nsdc patch is no longer necessary.
    - - nsd.db is memory mapped, NSD needs (part of) that mmap in ram.
    - - tcp-count can go above 1000; epoll/kqueue support with libevent.
    - - nsd-control reconfig for updates with no restart (zones, keys, ..)
    - - nsd-control-setup to create keys for nsd-control (enable nsd-control
    with remote-control: yes in nsd.conf).

    FEATURES (incremental from BETA5):
    - - configure --disable-recvmmsg for compat with older Linux kernels,
    by default it autodetects support in the kernel on the buildmachine.
    - - Fix time at 2038, uint32s changed to time_t, support 64bit time_t.
    - - Fix use of 32bit time, for 2038, thanks to Theo de Raadt for patch.
    BUG FIXES (incremental from BETA5):
    - - Bugfix#518 Incorrect RRL prefix length option names in nsd.conf
    man page from Ville Mattila.
    - - Fix that xfrd, and nsd-control, does not stop responding when reload
    errors out. The pid is sent like it should by server_main.
    - - Fix that EOF in quoted string error does not cause reload to exit.
    - - Fixup errors from the stack code checker.
    - - Removed use of random when arc4random is available. Thus, random
    and srandom are then not linked with the executable.
    - - Fix segfault with no logfile and chroot.
    - - Fix IXFR handling, that was discovered in the RC1. More leniently
    handle uppercase in RRSIG and NSEC rdata, during IXFRs. There is a
    fix as well as more detailed error logging for this case.
    - - Print slightly more human friendly TSIG errors and updated the
    manual page for the -d option for nsd.
    - - Fix (in rc3) where reconfig would not initialise zones that change
    from primary to secondary (due to config changes); those zones
    did not perform zone transfers right away, and they do now.


    パフォーマンスの改善やバグフィックスが大量に入っているので、気になる方はドキュメントを参照の上、導入を検討されては如何でしょうか?


    関連記事

    [Linux][自分用メモ] because parent directory has insecure permissions (It's world writable or writable by group which is not "root")が出た時の対処法。

     
    • 最終更新日時:-0001/11/30 00:00:00

    2011-08-29 - 菖蒲のころ /
    http://d.hatena.ne.jp/korokorokoron/20110829

    zabbix の2.0.9が出ていることに気がついて、コンパイルして導入したところ、そういえばlogローテーションをしていないことに気が付き、慌ててlogローテーションをするように設定したところ、以下の様なエラーが発生しました。

    logローテーションファイル(zabbix-agent)
    /var/log/zabbix/zabbix_agentd.log {
    rotate 7
    missingok
    monthly
    notifempty
    compress
    dateext
    create 0664 zabbix zabbix
    }
    エラーメッセージ
    # logrotate -f zabbix-agent
    error: skipping "/var/log/zabbix/zabbix_agentd.log" because parent directory has insecure permissions (It's world writable or writable by group which is not "root") Set "su" directive in config file to tell logrotate which user/group should be used for rotation.

    Googleで少し検索したところ、明示的にsuを与えてやることでこのエラーに対処することが出来るようです。ということでlogローテーションファイルを以下のように修正してみました。
    /var/log/zabbix/zabbix_agentd.log {
    rotate 7
    missingok
    daily
    notifempty
    compress
    dateext
    su zabbix zabbix
    create 0664 zabbix zabbix
    }
    こうすることでエラーメッセージが出力されないようになり、問題が改善したことを確認しました。
    # logrotate -v zabbix-agent
    reading config file zabbix-agent

    Handling 1 logs

    rotating pattern: /var/log/zabbix/zabbix_agentd.log after 1 days (7 rotations)
    empty log files are not rotated, old logs are removed
    switching euid to 993 and egid to 991
    considering log /var/log/zabbix/zabbix_agentd.log
    log does not need rotating
    switching euid to 0 and egid to 0

    今回の件で、logローテーションは奥が深いと感じ、また勉強不足だなぁと思いました。



    関連記事

    [MikroTik][Routerboard] MikroTik製品でNTP機能を使用する方法。 #routerboard

    • 2013/10/15 10:15:27
    • Category: mikrotik
     
    • 最終更新日時:-0001/11/30 00:00:00

    sntp1.png

    通常、RouterOSはSNTP Client機能を標準で提供していますが、RouterBoard自身がNTP Serverとしての機能を提供したいという時もあると思います。
    そういう時は、Mikrotik社のWebサイトから「All Packege」ファイルをダウンロードし、その中にあるNTPパッケージをRouterboardにuploadします。uploadする方法については、FTPやSCP、Winboxからのドラッグ・アンド・ドロップでも対応できます。
    ファイルをuploadすることが出来たら、一度Routerboardを再起動します。そうしないとパッケージが有効になりません。

    再起動を行って再度WinboxやWebfigで接続すると、「System」配下に、「NTP Client」と「NTP Server」が追加されていると思います。
    NTP Serverについては、以下の画像の通り有効化し、どのプロトコルでNTPを提供するかを選択します。
    ntp3.png

    NTP Clientについては、通常はunicastを選択し、NTPサーバを指定します。たしか、RouterOSのバージョンが6.4からはIPアドレスを直接指定しなくても良くなったはずなので、「ntp.nict.jp」や「ntp.jst.mfeed.ad.jp」を指定し、Applyをクリックします。そうすると、自動的にResolvされて、IPアドレスに変換されます。
    ntp2.png

    コマンドで指定する場合は、以下のように行います。
    [admin@MikroTik] > /system ntp client set enabled=yes mode=unicast \
    primary-ntp=[:resolv ntp.nict.jp] secondary-ntp=[:resolv ntp.jst.mfeed.ad.jp]


    SNTP Client機能だけだと物足りないなぁという人は以上のように、NTPパッケージを使用してみては如何でしょうか?



    関連記事

    [VMware][ESXi] 仮想マシンバージョンをロールバックする方法。10→9

     
    • 最終更新日時:-0001/11/30 00:00:00

    にほんごVMware: 仮想マシンバージョンのロールバック(vmx-09→8) | VMware Communities /
    https://communities.vmware.com/people/gowatana/blog/2012/12/23/%E4%BB%AE%E6%83%B3%E3%83%9E%E3%82%B7%E3%83%B3%E3%83%90%E3%83%BC%E3%82%B8%E3%83%A7%E3%83%B3%E3%81%AE%E3%83%AD%E3%83%BC%E3%83%AB%E3%83%90%E3%83%83%E3%82%AF-vmx-09-8


    vmx-10.png

    最新のVMware vSphere Hypervisor 5.5 では仮想マシンバージョンが10になっています。
    が、10にアップグレードすると、上記の画像のようにvShpere Clientから設定の編集が行えなくなってしまいます。
    ということで仮想マシンバージョンを一時的にでもダウングレードしたい場合、以下の方法を行うことで仮想マシンバージョンのダウングレードが行えます。

    関連記事

    [mikrotik][RouterOS] RouterOS のconfigをGmailで送信するスクリプトを修正してみた。 #routerboard

    • 2013/10/04 10:00:08
    • Category: mikrotik
     
    • 最終更新日時:-0001/11/30 00:00:00

    いつか、そのとき、あの場所で。 | [mikrotik][RouterOS] RouterOS のconfigをGmailで送信するスクリプト。 /
    http://kometchtech.blog45.fc2.com/blog-entry-1206.html

    以前にRouterboardのconfigをGmailに送信してバックアップする記事を書きましたが、送信先のメールサーバーのアドレスをIPアドレス直接指定するという、何とも気持ち悪い書き方だったのですが、名前解決する方法が分かったので、修正してみました。

    # 修正前
    /tool e-mail send server=74.125.143.108
    # 修正後
    /tool e-mail send server=[:resolv smtp.gmail.com]

    この様に記述を変更することで、名前解決が出来るようになりました。勿論RB自体にDNS設定が入っていることが前提ですが。

    使用できるグローバルコマンドについては以下を参照してください。
    Manual:Scripting - MikroTik Wiki /
    http://wiki.mikrotik.com/wiki/Manual:Scripting#Global_commands




    関連記事

    [Mikrotik][#Routerboard ] RouterboardシリーズでHurricane Electric IPv6 Tunnel Brokerを利用してIPv6を利用する方法。 #ipv6study

    • 2013/10/03 10:16:01
    • Category: mikrotik
     
    • 最終更新日時:-0001/11/30 00:00:00

    最近巷で流行の兆しが見えてきている、MikroTik社のRouterboardですが、自宅でIPv6を使用したいけど、使用できないという方は、Hurricane Electric IPv6 Tunnel Broker(以下HE.net)というサービスがあります。
    ここは無償でIPv6アドレスのTunnelを作り仮想的にIPv6アドレスを払いだしてくれるサービスです。
    というわけで、RouterboardでHE.netを利用するコマンドを以下に紹介します。
    /interface 6to4 add comment="Hurricane Electric IPv6 Tunnel Broker" \
    disabled=no local-address=<ルータ側に割り当てられたIPv6アドレス> \
    mtu=1280 name=sit1 remote-address=<he.netの対向のIPv4アドレス>
    /ipv6 route add comment="" disabled=no distance=1 dst-address=2000::/3 \
    gateway=<Server IPv6 Address:で指定されているIPv6アドレス> scope=30 target-scope=10
    /ipv6 address add address=<Client IPv6 Address:で指定されているIPv6アドレス> \
    advertise=yes disabled=no eui-64=no interface=sit1


    一旦ここでRouterboard自身からping6を実行し、間違いなくIPv6通信ができることを確認します。
    [admin@MikroTik] > ping [:resolve ipv6.google.com]
    HOST SIZE TTL TIME STATUS
    2404:6800:4004:805::1012 56 59 15ms echo reply
    2404:6800:4004:805::1012 56 59 8ms echo reply
    2404:6800:4004:805::1012 56 59 7ms echo reply
    2404:6800:4004:805::1012 56 59 15ms echo reply
    2404:6800:4004:805::1012 56 59 9ms echo reply
    2404:6800:4004:805::1012 56 59 7ms echo reply
    2404:6800:4004:805::1012 56 59 15ms echo reply
    sent=7 received=7 packet-loss=0% min-rtt=7ms avg-rtt=10ms max-rtt=15m

    あとは、RouterBoard自身のDHCPv6Server機能を利用して、内側のネットワーク内にIPv6を払い出すようにしてやることで、外部にIPv6通信ができるようになると思います。

    /ipv6 dhcp-server
    add address-pool=he.net disabled=no interface=internal name=kometch.local
    /ipv6 pool
    add name=he.net prefix=<HE.netで払いだされたIPv6アドレスレンジ>/64 prefix-length=64
    /ipv6 address
    add address=<Server IPv6 Address:で指定されたIPv6アドレス> comment="default gateway ipv6" interface=internal
    add address=<Client IPv6 Address:で指定されたIPv6アドレス> interface=sit1
    add distance=1 dst-address=2000::/3 gateway=<HE.netで払いだされたIPv6アドレスレンジ>
    /ipv6 firewall filter
    add chain=input comment="Router - Allow IPv6 ICMP" protocol=icmpv6
    add chain=forward comment="LAN - Accept ICMPv6 " protocol=icmpv6
    add chain=input comment="Router - Accept established connections" connection-state=\
    established
    add chain=input comment="Router - Accept related connections" connection-state=related
    add chain=input comment="Router- UDP" protocol=udp
    add chain=forward comment="LAN - Accept UDP" protocol=udp
    add chain=forward comment="LAN - Accept established Connections" connection-state=\
    established
    add chain=forward comment="LAN - Accept related connections" connection-state=related
    add action=log chain=forward comment="LAN - Log everything else" disabled=yes \
    log-prefix="Log IPv6"
    add action=drop chain=input comment="Router - Drop invalid connections" \
    connection-state=invalid
    add action=drop chain=input comment="Router - Drop other traffic"
    add action=drop chain=forward comment="LAN - Drop invalid Connections" connection-state=\
    invalid
    /ipv6 settings
    set accept-router-advertisements=yes

    後は内側にあるPCからもpingを実行し、外部とのIPv6通信の疎通ができることを確認します。
    C:\Users\kometch>ping -6 ipv6.google.com

    ipv6.l.google.com [2404:6800:4004:805::1012]に ping を送信しています 32 バイトの
    データ:
    2404:6800:4004:805::1012 からの応答: 時間 =8ms
    2404:6800:4004:805::1012 からの応答: 時間 =9ms
    2404:6800:4004:805::1012 からの応答: 時間 =10ms
    2404:6800:4004:805::1012 からの応答: 時間 =12ms

    2404:6800:4004:805::1012 の ping 統計:
    パケット数: 送信 = 4、受信 = 4、損失 = 0 (0% の損失)、
    ラウンド トリップの概算時間 (ミリ秒):
    最小 = 8ms、最大 = 12ms、平均 = 9ms

    今回は全てコマンドで実施しましたが、これらの操作は全てWebfigならびにWinBoxを利用したGUIからも行うことが出来ます。

    それでは楽しいIPv6ライフを。



    関連記事

    [備忘録][処方箋] 27回目のお薬。弟との共同生活が始まって約1ヶ月。

     
    • 最終更新日時:2016/10/02 17:19:01

    名称色・形・記号用法服用タイミング
    アモキサンカプセル25mg淡赤褐:白/赤1夕食後服用内服薬    1cap
    ジェイゾロトフ錠50mg白/楕円形1夕食後服用内服薬    1錠
    ドグマチール錠50mg白帯/黄白/錠1夕食後服用内服薬    1錠
    リボトリール錠2mg白/錠1夕食後服用内服薬    1錠

    個人的には話し相手が出来て、精神的に安定してきたような気がします。
    とりあえず医師からは様子を見ましょうと、相変わらずの返事でしたが、近いうちに薬の量も減らせるのではないかなと思っています。

    早く身体を治して色々なことに精力的に取り組んでいきたいです。



    関連記事

    [MikroTik][RouterBoard] #自宅ラック勉強会 #15.1 RouterBoard勉強会 Vol.2 開催のお知らせ #routerboard #bmstudy #ipv6study

    • 2013/10/01 10:41:23
    • Category: mikrotik
     
    • 最終更新日時:-0001/11/30 00:00:00

    自宅ラック勉強会 #15.1 RouterBoard勉強会 Vol.2 - connpass /
    http://connpass.com/event/3512/

    再びですが、MikroTik社のRouterboardに関する勉強会の第2回を開催することになりました。

    今度はベンチマーク勉強会と合同で、テーマは「Mikrotik社のRouterBoard&CCRを色々ハンズオン&ベンチマーク」となります。
    MikroTik社のRouterboard製品を多数集めて、色々と性能試験をしてみようという内容になります。
    いかにコストパフォーマンスに優れているのか、VPNの性能は?などなど、良くも悪くも分かっていないRouterboard製品をいじり倒す勉強会になりそうです。

    Routerboardが気になっている方や、性能はどうなんだろうという疑問をお持ちの方は、是非参加してみてはいかがでしょうか?



    関連記事

    Pagination

    Utility

    Profile

    kometch

    Author:kometch
    なんちゃってエンジニアです。
    2009年10月から業務都合により大阪勤務になりました。
    2010年1月、HYBRID W-ZERO3を購入しました。
    2010年11月、HTC Desire HDを購入しました。
    2012年2月、都内の会社に転職しました。
    2012年5月、HTC One Xを購入しました。
    2012年8月、事情により休職しました。
    2012年8月、SONY Xperia SXを購入しました。
    2013年1月、一身上の都合により退職しました。
    2014年3月、都内の会社に就職しました。
    2016年8月、HPC系の会社に転職しました。

    Amazonほしい物リスト
    何か問題などありましたら、こちらまで。 Twitter:@kometchtech follow us in feedly

    カレンダー

    09 | 2013/10 | 11
    - - 1 2 3 4 5
    6 7 8 9 10 11 12
    13 14 15 16 17 18 19
    20 21 22 23 24 25 26
    27 28 29 30 31 - -

    全記事(数)表示

    全タイトルを表示

    バロメーター

    カテゴリー

    カテゴリークラウド

    アーカイブ

    検索フォーム

    FC2カウンター

    現在の閲覧者数

    現在の閲覧者数:

    Amazonアソシエイト

    スポンサードリンク

    月間ページランキング

    ブログパーツ

    サイトランキング

    スポンサードリンク

    スポンサードリンク