[ #routerboard ][ #mikrotik ] RouterOSでCountry Blockを使用する方法。

    Related Posts Plugin for WordPress, Blogger...
    Country CIDR IP ranges | blog.erben.sk /
    http://blog.erben.sk/2014/02/06/country-cidr-ip-ranges/

    RouterOSを使用しているとどうしても使用する場面が想定されるCountry Block(国別防御)だと思いますが、RouterOSには標準では機能として搭載されていません。

    しかし同じような事を考える人が多いらしく、過去にはScriptが組まれていたのですが、最近のRouterOSでは動作しないことが確認されています。

    しかし、態々国別のCIDRをRouterOSの仕様にしてリスト化しているサイトが有りました。

    検証環境:
    RouterOS 6.15

    Index of /ipcountry /
    http://www.iwik.org/ipcountry/

    まずはScriptを2つ作成します。
    一つは該当するリストの削除。もう一つはCIDRリストのダウンロードし、アドレスリストとして登録するScriptになります。

    リストを削除するScriptは以下になります。今回はロシアのリストがある前提です。
    [admin@MikroTik] /system script> add name=remove_russia policy=ftp,read,write,policy,test,winbox,api source="\
    \n:foreach i in=[/ip firewall address-list find ] do={\
    \n:if ( [ /ip firewall address-list get \$i list ] = \"RU\" ) do={\
    \n/ip firewall address-list remove \$i\
    \n}\
    \n}\
    \n"

    そして、もう一つはロシアのCIDRリストをダウンロードするScriptになります。
    [admin@MikroTik] /system script> add name=download_RU policy=read,write,test,polic
    icy source={
    {... /tool fetch url=http://www.iwik.org/ipcountry/mikrotik/RU
    {... /import file-name=RU
    {... }

    そして、これらを1日1回のペースで実行するようにスケジューラーに登録します。
    /system scheduler
    add interval=1d name=CB_RU on-event="/system script run remove_russia\r\
    \n:delay 30\r\
    \n/system script run download_RU" policy=\
    ftp,read,write,policy,test,winbox,api start-time=startup

    一応一つのScriptとしてまとめて実行することは可能ですが、対象とする国が増えたりする場合、メンテナンス性を考慮すると面倒でも国別にScriptを分けて実行したほうがいいと思います。

    そして、最後にfirewall filterにdropするように登録して終了です。
    /ip firewall filter
    add action=drop chain=input comment=Country_Block_Russia src-address-list=RU


    RB750GLRB750GL


    MikroTik
    売り上げランキング : 75088

    Amazonで詳しく見る by AZlink

    RB2011UiAS-INRB2011UiAS-IN


    MikroTik
    売り上げランキング : 92440

    Amazonで詳しく見る by AZlink


    Pagination

    Trackback

    Trackback URL

    http://kometchtech.blog.fc2.com/tb.php/1544-8612d616

    Comment

    Post Your Comment

    コメント登録フォーム
    公開設定

    Utility

    Profile

    kometch

    Author:kometch
    なんちゃってエンジニアです。
    2009年10月から業務都合により大阪勤務になりました。
    2010年1月、HYBRID W-ZERO3を購入しました。
    2010年11月、HTC Desire HDを購入しました。
    2012年2月、都内の会社に転職しました。
    2012年5月、HTC One Xを購入しました。
    2012年8月、事情により休職しました。
    2012年8月、SONY Xperia SXを購入しました。
    2013年1月、一身上の都合により退職しました。
    2014年3月、都内の会社に就職しました。
    2016年8月、HPC系の会社に転職しました。

    Amazonほしい物リスト
    何か問題などありましたら、こちらまで。 Twitter:@kometchtech follow us in feedly

    カレンダー

    06 | 2017/07 | 08
    - - - - - - 1
    2 3 4 5 6 7 8
    9 10 11 12 13 14 15
    16 17 18 19 20 21 22
    23 24 25 26 27 28 29
    30 31 - - - - -

    全記事(数)表示

    全タイトルを表示

    バロメーター

    カテゴリー

    カテゴリークラウド

    アーカイブ

    検索フォーム

    FC2カウンター

    現在の閲覧者数

    現在の閲覧者数:

    Amazon アフィリエイト

    スポンサードリンク

    Latvia Time

    IPv4/IPv6

    月間ページランキング

    ブログパーツ

    サイトランキング

    スポンサードリンク