[ #mikrotik ][ #routerboard ] Cloud Core RouterにおけるCPUの割り当てについて。

    Related Posts Plugin for WordPress, Blogger...
    rps.png

    Manual:IP/IPsec - MikroTik Wiki /
    http://wiki.mikrotik.com/wiki/Manual:IP/IPsec#Hardware_encryption

    ちょっと探しものをしていたらネタを発見したので書いておきます。

    MikroTikのCloud Core RouterシリーズおよびRB1100シリーズはメニーコアモデルになります。
    が、通常の状態だとどうしてもIRQによる制御において偏りが発生し、特にIPsecなどを張っている場合には、一つのコアに処理が集中し、全体の処理が遅くなる、または動作不全に陥ることがあります。
    先の画像でも示しているように、CCR1009の場合はActiveになるCPUが全体に均等に割り当てられているのですが、なぜか偏りが発生します。

    CCRシリーズで採用しているTileraはCPU自体がハードウェア暗号化に対応しているのですが、その設定についてなんとデフォルトで無効になっているようです。それに関連して、CPUの割り当てを動的に手動で固定割り当てする方法がありました。

    前提条件として、すべてのインターフェースキューが"only-hardware-queue"であること、RPSをdisableにすることのようです。
    /queue interface set [find] queue=only-hardware-queue
    /system resource irq rps disable [find]

    [admin@MikroTik] /system resource irq> print
    Flags: ro - read-only
    # IRQ USERS CPU ACTIVE-CPU COUNT
    0 1 MicroSD auto 0 0
    1 2 eth phy auto 1 4
    2 3 eth auto 2 3 647 200
    3 4 eth auto 3 3 827 661
    4 5 ts auto 4 0
    5 6 crypto auto 5 0
    6 7 usb1 auto 6 0
    7 8 Fancon auto 7 36 932 143
    8 9 usb2 auto 8 2

    IRQ4に割り当てられているCPUをautoからCPU0に固定的に割り当てるには以下の様な感じになります。

    [admin@MikroTik] /system resource irq> set cpu=0 numbers=3
    [admin@MikroTik] /system resource irq> print
    Flags: ro - read-only
    # IRQ USERS CPU ACTIVE-CPU COUNT
    0 1 MicroSD auto 0 0
    1 2 eth phy auto 1 4
    2 3 eth auto 2 3 656 544
    3 4 eth 0 0 3 837 787
    4 5 ts auto 3 0
    5 6 crypto auto 4 0
    6 7 usb1 auto 5 0
    7 8 Fancon auto 6 37 015 727
    8 9 usb2 auto 7 2

    アクティブとして割り当てられたCPUが0になっているのが分かるでしょうか?
    MikroTikのWikiによると、これらの割り当てを固定的に割り振ることで、スループットの向上にも繋がるとのことが書いてあります。

    この辺りの動作についてはドキュメントベースでしか確認していないので、時間を取ってTraffic Generatorなどを使いながら検証しようかと思います。

    参考:
    CentOS 6.2 で RPS/RFS を使ってネットワークの割り込み処理を複数コアに分散してみた - blog.nomadscafe.jp /
    http://blog.nomadscafe.jp/2012/08/centos-62-rpsrfs.html

    VIOPS06で「RPS・RFS等最新Linux Kernel事例」と題してお話してきました - かーねる・う゛いえむにっき /
    http://d.hatena.ne.jp/syuu1228/20110722/1311322653

    RB2011UiAS-INRB2011UiAS-IN


    MikroTik
    売り上げランキング : 59372

    Amazonで詳しく見る by AZlink

    RB750GLRB750GL


    MikroTik
    売り上げランキング : 129179

    Amazonで詳しく見る by AZlink


    Pagination

    Trackback

    Trackback URL

    http://kometchtech.blog.fc2.com/tb.php/1512-12379185

    Comment

    Post Your Comment

    コメント登録フォーム
    公開設定

    Utility

    Profile

    kometch

    Author:kometch
    なんちゃってエンジニアです。
    2009年10月から業務都合により大阪勤務になりました。
    2010年1月、HYBRID W-ZERO3を購入しました。
    2010年11月、HTC Desire HDを購入しました。
    2012年2月、都内の会社に転職しました。
    2012年5月、HTC One Xを購入しました。
    2012年8月、事情により休職しました。
    2012年8月、SONY Xperia SXを購入しました。
    2013年1月、一身上の都合により退職しました。
    2014年3月、都内の会社に就職しました。
    2016年8月、HPC系の会社に転職しました。

    Amazonほしい物リスト
    何か問題などありましたら、こちらまで。 Twitter:@kometchtech follow us in feedly

    カレンダー

    05 | 2017/06 | 07
    - - - - 1 2 3
    4 5 6 7 8 9 10
    11 12 13 14 15 16 17
    18 19 20 21 22 23 24
    25 26 27 28 29 30 -

    全記事(数)表示

    全タイトルを表示

    バロメーター

    カテゴリー

    カテゴリークラウド

    アーカイブ

    検索フォーム

    FC2カウンター

    現在の閲覧者数

    現在の閲覧者数:

    Amazon アフィリエイト

    スポンサードリンク

    Latvia Time

    IPv4/IPv6

    月間ページランキング

    ブログパーツ

    サイトランキング

    スポンサードリンク