[ #mikrotik ][ #routerboard ] CAPsMANの設定使用方法。

    Related Posts Plugin for WordPress, Blogger...
    Manual:CAPsMAN - MikroTik Wiki /
    http://wiki.mikrotik.com/wiki/Manual:CAPsMAN

    現在プレビューbuild扱いになっているControlled Access Point system Manager (CAPsMAN)ですが、こちらについて少し設定ならびに使用方法を書いておこうと思います。
    # ROS 6.14からはWirelessパッケージに正式にマージされるそうです。

    なお日本国内で使用できる無線LAN対応機種は、執筆時点ではRB951Ui-2HnDおよび、R52n-M(W52)ですのでご注意ください。

    Untitled.png

    今回は一番シンプルな構成で説明します。
    検証環境:RouterOS version: 6.14rc8

    1. まず対象となるCAPsMANおよびにCAP(Controlled Access Points)にWireless-fpパッケージを導入します。

    2. CAPsMANで以下のようにコマンドを実行する。

    /caps-man manager
    set ca-certificate=auto certificate=auto enabled=yes require-peer-certificate=yes

    3. 自己証明書などが作成されていることを確認する。

    [admin@MikroTik] /caps-man manager> print
    enabled: yes
    certificate: auto
    ca-certificate: auto
    require-peer-certificate: yes
    generated-certificate: CAPsMAN-D4CA6DFA3854
    generated-ca-certificate: CAPsMAN-CA-D4CA6DFA3854

    4. 一旦、CAP側の設定に移ります。以下のコマンドを実行し、CAPsMANに接続できるようにします。
    /interface wireless cap
    set bridge=bridge1 caps-man-addresses=<CAPsMANのIPアドレス> caps-man-certificate-common-names=\
    CAPsMAN-D4CA6DFA3854 certificate=request discovery-interfaces=ether1 enabled=yes \
    interfaces=wlan1,wlan2 lock-to-caps-man=yes
    # bridge:local forwarding mode を使用する際に、どのbridgeに所属するかを設定します。
    # discovery-interfaces:CAPsMANを探索するためのインタフェース

    5. 再度CAPsMANの方に戻ります。こちらではCAPに対して下のパラメータを設定していきます。
    • channel
    • datapath
    • security
    • configuration

    6. まず最初にchannelを設定していきます。以下のようにコマンドを入力していきます。
    /caps-man channel
    add band=2ghz-b/g/n extension-channel=Ce frequency=2422 name=24-1 width=20 tx-power=10
    # basd:2ghz-b、2ghz-b/g/n、2ghz-onlyn、2ghz-b/g、2ghz-onlyg
    # extension-channel:40MHz拡張の際のどちらを優先するか。
    # frequency:現時点では周波数を直接指定する形となります。(将来的にはチャンネルで指定できるようになるかもしれません)
    # name:この設定テンプレートの名称
    # width:チャンネル幅
    # tx-power:こちらは10(dBm)を指定してください。

    7. 次にdatapathの設定を行います。これは関連するデータ転送を制御します。
    /caps-man datapath
    add bridge=bridge1 client-to-client-forwarding=yes local-forwarding=no name=datapath1
    # bridge:CAPをCAPsMANのどのbridgeインタフェースに所属させるか
    # client-to-client-forwarding:CAPでのクライアント通信を許容するかどうか
    # local-forwarding:CAPはCAPsMANにはさんかするが、制御下には行われずCAPは通常のAPとして動作します
    # name:設定テンプレートの名称

    8. 次にsecurity設定を行います。
    /caps-man security
    add authentication-types=wpa2-psk encryption=aes-ccm group-encryption=aes-ccm name=\
    hogehoge passphrase=hogehoge
    # authentication-types:無線LANの認証方式を選択します。選べるのは以下のとおり。wpa-psk、wpa2-psk、wpa-eap、wpa2-eap
    # encryption:暗号化方式を選択します。aes-ccmかtkipになります。
    # group-encryption:上記と同じく暗号化方式を選択します。
    # name:設定の名称を入力します。
    # passphrase:パスワードを入力します。

    9. 最後に上記で設定したテンプレートをconfigurationに落とし込みます。
    [admin@MikroTik] /caps-man configuration> 
    add name=test channel=24_1 security=Felix-g datapath=datapath1 country=japan ssid=test mode=ap \
    hide-ssid=yes rx-chains=0,1 tx-chains=0,1
    # name;設定テンプレートの名称
    # channel:上記のchannelテンプレートの名称
    # security:上記のsecurityテンプレートの名称
    # datapath:上記のdatapathテンプレートの名称
    # country:必ずjapanに指定してください。
    # ssid:SSID名称を指定します。
    # mode:APに自動的に指定されます。
    # hide-ssid:SSIDを隠すかどうかを指定します。
    # rx-chains、tx-chains:送受信に使用するアンテナを指定します。

    10. 接続されているCAPのMACアドレスを控えておく。
    [admin@MikroTik] /caps-man radio> print
    Flags: L - local, P - provisioned
    # RADIO-MAC INTERFACE REMOTE-AP-IDENT

    11. configurationに落とし込んだ設定をCAPに設定します。
    /caps-man interface
    add arp=proxy-arp channel=hoehoge configuration=hogehoge datapath=hogehoge\
    disabled=no l2mtu=1600 mac-address=xx:xx:xx:xx:xx:xx master-interface=none \
    mtu=1500 name=hogehoge radio-mac=xx:xx:xx:xx:xx:xx security=hogehoge
    # channel:上記のchannelで設定したテンプレートの名称を入力する
    # configuration:上記のconfigurationで設定したテンプレートの名称を入力する。
    # datapath:上記のdatapathで設定したテンプレートの名称を入力する。
    # mac-address:上記で出てきたMACアドレスを入力する。
    # master-interface:VirtualAPの場合は、ひもづけるMaster-interfaceを指定する。
    # name:この設定の名称
    # radio-mac:入力しなくても良いが、出来れば明示的に先ほど調べたMACアドレスを入力する。
    # security:上記のsecurityで設定したテンプレートの名称を入力する。

    以上で、CAPsMANからCAPを制御し、かつCAPにPCから接続できるようになると思います。




    Pagination

    Trackback

    Trackback URL

    http://kometchtech.blog.fc2.com/tb.php/1495-53daf2b6

    Comment

    Post Your Comment

    コメント登録フォーム
    公開設定

    Utility

    Profile

    kometch

    Author:kometch
    なんちゃってエンジニアです。
    2009年10月から業務都合により大阪勤務になりました。
    2010年1月、HYBRID W-ZERO3を購入しました。
    2010年11月、HTC Desire HDを購入しました。
    2012年2月、都内の会社に転職しました。
    2012年5月、HTC One Xを購入しました。
    2012年8月、事情により休職しました。
    2012年8月、SONY Xperia SXを購入しました。
    2013年1月、一身上の都合により退職しました。
    2014年3月、都内の会社に就職しました。
    2016年8月、HPC系の会社に転職しました。

    Amazonほしい物リスト
    何か問題などありましたら、こちらまで。 Twitter:@kometchtech follow us in feedly

    カレンダー

    05 | 2017/06 | 07
    - - - - 1 2 3
    4 5 6 7 8 9 10
    11 12 13 14 15 16 17
    18 19 20 21 22 23 24
    25 26 27 28 29 30 -

    全記事(数)表示

    全タイトルを表示

    バロメーター

    カテゴリー

    カテゴリークラウド

    アーカイブ

    検索フォーム

    FC2カウンター

    現在の閲覧者数

    現在の閲覧者数:

    Amazon アフィリエイト

    スポンサードリンク

    Latvia Time

    IPv4/IPv6

    月間ページランキング

    ブログパーツ

    サイトランキング

    スポンサードリンク